Gmail-related email delivery delays

Incident Report for Turnkey

Resolved

Gmail email delivery has returned to normal and delayed login and signup emails are now being delivered as expected.
Posted Jan 24, 2026 - 18:12 EST

Identified

We’ve identified delays in delivery of login and signup emails for users with Gmail addresses.

This is due to an ongoing Gmail email delivery issue and is not caused by Turnkey infrastructure. Emails to non-Gmail providers are delivering normally.

We’ll continue to monitor Gmail delivery behavior and provide updates if the situation changes. For updates:

https://www.google.com/appsstatus/dashboard/incidents/NNnDkY9CJ36annsfytjQ
Posted Jan 24, 2026 - 12:47 EST