Database performance degradation

Incident Report for Turnkey

Resolved

This incident has been resolved.
Posted Mar 01, 2026 - 14:09 EST

Monitoring

We have rolled out an update and are monitoring results.
Posted Mar 01, 2026 - 13:36 EST

Investigating

We are experiencing intermittent request timeouts due to a database performance degradation.

The team is actively investigating the underlying cause and working to restore full performance. We will share additional details as we have them.
Posted Mar 01, 2026 - 12:24 EST
This incident affected: APIs.