Increased latency across activity types

Incident Report for Turnkey

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 13:41 EDT

Investigating

We are currently observing increased latency across multiple activity types. The source of the issue has not yet been identified, and our engineering team is actively investigating. We will provide updates as more information becomes available.
Posted Aug 21, 2025 - 13:34 EDT
This incident affected: API.