Email delivery issues for Turnkey Dashboard users

Incident Report for Turnkey

Resolved

This incident has been resolved.
Posted Jan 30, 2026 - 10:19 EST

Monitoring

We’ve deployed a fix, functionality should be returning to normal, and we’re actively monitoring to ensure stability.
Posted Jan 30, 2026 - 09:10 EST

Investigating

We’re aware of an issue preventing magic link emails from being sent on the Turnkey Dashboard.
The issue is limited to new user invites and users who haven’t logged in recently. Existing sessions and other functionality remain unaffected.
Posted Jan 30, 2026 - 07:53 EST
This incident affected: Dashboard.