Polygon mainnet broadcasting unavailable

Incident Report for Turnkey

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 04:27 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2026 - 03:20 EDT

Investigating

We're currently investigating an issue with the underlying RPC providers for Polygon. All other chains and Turnkey services are operating normally.
Posted Jun 26, 2026 - 02:53 EDT
This incident affected: Transaction Management (Transaction Broadcasting, Gas Sponsorship).